Cannot create Tasks, Task Manager Blank

Discussion in 'FOG Problems' started by Gimic, Nov 9, 2012.

  1. Gimic New Member

    Trying out Fog and trying to create an image and was getting to do my first upload to create the image and I ran into a problem creating a task to do the upload.

    I click on my Host Management, then select the Host I want to make an image from then click on "Basic Tasks" on the left side and selected "Upload". Once I left click "Upload" it takes me to the Task Management section but all I have is a blank page with the Fog Menu at the top and below that it says Task Management and doesn't allow me to do anything else.
  2. rma New Member

    Just finished setting up Fog 0.32 on Ubuntu 12.10 today, and I am experiencing exactly the same problem. I've got a host & image created, but when I attempt to upload it sends me to a blank Task Management page with no options or buttons. Anyone have ideas or suggestions? Thanks.
  3. chad-bisd Community Manager

    Gimic, when posting for help, please include information about the version of FOG you have installed, the version of the OS you are running, and any updates/modifications you have installed. Any bit of info helps.

    Have you tried in multiple browsers? I know sometimes things don't show up in Chrome, but work fine in IE/Firefox. If that doesn't work, you can try looking at the apache log files as you try to schedule a task and see if an error is being reported there.
  4. rma New Member

    Hi Chad. Thanks for the response. I tried different browsers and from different machines with the same result. I am fairly noobish when it comess to linux, but I managed to find the apache logs. here's what I am seeing:

    I'm not sure what that means though - like I said, I'm new to this. Did I not configure something corrrectly?
  5. chad-bisd Community Manager

    The undefined index errors can be ignored. The call-time pass-by-reference is probably the culprit. Take a look at the code in the /var/www/fog/management/includes/tasks.confirm.include.php line 754 and take the "&" out of the function call argument list. Save the file and try again.
  6. rma New Member

    I tried removing the '&' symbol from the argument list, but that doesn't seem to have made a difference.
  7. chad-bisd Community Manager

    try to schedule a task again, look at the apache logs, see what the errors are now, ignoring the undefinded index errors.
  8. rma New Member

    Well, thank you for your suggestions chad-bisd; I think we've found a solution. Every time I would try to schedule a task I'd see another error similar to the one above show up in the apache logs. At the end of the line I found "&$tmp". After removing the '&' symbol I would get another error, but referencing new line, which would of course have "&$tmp" at the end. I finally did a search/replace on all instances of "&$tmp" replacing them with "$tmp" (just removing the & symbol). Immediately after that I tried to schedule an upload and was met with the correct confirmation screen under task management.

    Thank you for your help.


    For other users with this issue, here is specifically what I did. I can't guarantee it will work for everyone, but it seems to have corrected it for me at least:

    gksu gedit /var/www/fog/management/includes/tasks.confirm.include.php
    Search Menu > Replace
    Search for: &$tmp
    Replace with: $tmp
    Replace All (there were somewhere around twenty instances)
    Save
    Close
    Then try to schedule your upload task again.
    ExtraordinaryBen likes this.
  9. Fred New Member

    It's just magic, i replaced the "&$tmp" and it works for me.
    Anyone knows what's the source problem?

    A php update?

    Thanks for the help gents!

    Regards,
    Fred
  10. chad-bisd Community Manager

    Newer versions of PHP no longer accept function calls with arguments explicitly passed by reference. It's been deprecated for several releases of PHP, but still worked. It does not work anymore. The function definition must specify whether the argument is passed by value or by reference, and the function call just needs to specify the variable name or value without the &
    Fred likes this.
  11. Corey kelly New Member

    Amazing... it worked perfectly :)
  12. 7rox New Member

    Thanks rma (a year later), that solved my issue too! For anyone else running FOG headless, this single command fixes it:

    sed 's:&$tmp:$tmp:' -i /var/www/fog/management/includes/tasks.confirm.include.php

    For those unfamiliar with sed, the command simply replaces "&$tmp" with "$tmp" in the file.
    Jaymes Driver likes this.

Share This Page