Dell OptiPlex 790 in loop

Discussion in 'General' started by Peter Nowak, Mar 26, 2012.

  1. Peter Nowak New Member

    Hi all happy FOG users,

    I'm a total noob on FOG and only just started to use it hoping that I could image a couple of Dell OptiPlex 790 PC. The problem is that when you set these PCs up to boot from the NW with PXE they go into a endless loop when no task is set up for them and they try and boot from HD.

    I know that this is caused by the PC itself as it "resets" when it should just continue and boot from the HD so I assumed a new BIOS would hopefully fix it, so I was happy to see a v. A11 on Dell's support page but no luck unfortunately, same problem. Any suggestions?

    Thanks in advance!
  2. Kyley Holloway New Member

    Update to the newest kernel.
  3. ssx4life Member

    It's a reported issue for this model. You can also check the forums to see other workarounds using the PXE boot menu if you want. =)
  4. BryceZ Community Manager

  5. Peter Nowak New Member

    Many thanks for all replies! Great to see that this forrum is so active! I'll look into updating to the latest kernel first as suggested and see how I get on, thakns again everyone!
  6. Derek Boyer New Member

    I had to use the chainloading artice that BryceZ posted a link to for that model to work. I was getting the infinite booting loop as well
  7. Peter Nowak New Member

    Hi BryceZ,

    First of all thanks for your suggestion and sorry for the loong delay in doing this! Reading some other post seem to indicate that this really is a good solution, I've tried to do this now and had some problems. I'm a total noob at linux CLI so I'm sure I've buggered something up, here is what I did using the CLI:

    [root@frfrg001 ~]# cp /tftpboot/pxelinux.0 /tftpboot/pxelinux.0_20120515
    [root@frfrg001 ~]# cp /tftpboot/vesamenu.c32 /tftpboot/vesamenu.c32_20120515
    [root@frfrg001 ~]# vi /tftpboot/pxelinux.cfg/default
    [root@frfrg001 scratch]# cd /scratch
    [root@frfrg001 scratch]# ll
    total 224
    -rwx------ 1 jhnowaki rme 20704 May 15 16:41 chain.c32
    -rwx------ 1 jhnowaki rme 26460 May 15 16:41 pxelinux.0
    -rwx------ 1 jhnowaki rme 155792 May 15 16:41 vesamenu.c32
    [root@frfrg001 scratch]# cp ./* /tftpboot
    cp: overwrite `/tftpboot/pxelinux.0'? y
    cp: overwrite `/tftpboot/vesamenu.c32'? y
    [root@frfrg001 scratch]#

    As I am using the text based menu (I think?) I modified the first line of /tftpboot/pxelinux.cfg/default from DEFAULT vesanebu.c32” -> “DEFAULT fog.nextand added the rest of the text.
    And what I'm getting now when trying to boot ANY PC into FOG is this:

    Missing parameter in configuration file. Keyword: \n
    Missing parameter in configuration file. Keyword: \n
    Missing parameter in configuration file. Keyword: \n
    Missing parameter in configuration file. Keyword: \n
    Missing parameter in configuration file. Keyword: \n

    Could not find kernel image: chain.c32
    Boot:
    Could not find kernel image: chain.c32
    Boot:
    Could not find kernel image: chain.c32
    Boot:
    Could not find kernel image: chain.c32
    Boot:
    Could not find kernel image: chain.c32
    Boot:


    Any idea what I've done wrong? Oh, and I used the v.4.05 SYSLINUX files.

    Many thanks in advance for your help!
  8. BryceZ Community Manager

    Off the top of my head I'd say it's a permissions issue. It looks like you're only giving access to the owner (in this case jhnowaki), which may not match the read access needed for TFTP.. try chmod 644 on chain.c32 pxelinux.0 and vesamenu.c32, just to make sure it's not a read issue.
  9. Peter Nowak New Member

    Thanks BryceZ, just another quick (probably stupid) question, what is the difference between the "text menu" or the "graphical menu" as I'm starting to doubt which one I'm using...

    When successfully loaded, I see a graphical "FOG logo" and underneith, I see all the options in the menu which I can highlight using the arrow keys (enter selects) and it all looks "text based" but am I perhaps using "Graphical menus" ?
  10. BryceZ Community Manager

    This is the default graphical menu:
    [IMG]
  11. Peter Nowak New Member

    Thanks again, I can't seem to see the image, I am logged in using IE9 but the image is just a "X "
    is there another way you could send me this image like directly PM or similar or perhaps a link to someone showing how the graphical menu looks?

    Thanks, again!
  12. BryceZ Community Manager

    Of course it doesn't work, because I wasn't thinking and linked to an image on a secured site. I've attached a copy of the image to this post.

    Attached Files:

    Peter Nowak likes this.
  13. Peter Nowak New Member

    Much better! Great stuff, now I think I know where I'm going wrong, I am in fact using the "Graphical menu" so I have edited the wrong file! I'll get try to change this again tomorrow, many thanks again!
  14. Peter Nowak New Member

    Right, getting closer now (I think)
    Having gone back to the original /tftpboot/pxelinux.cfg/default as I wrongly edited it. I now edited fog.local in /tftpboot/pxelinux.cfg/default instead to look like:

    LABEL fog.local
    kernel chain.c32
    append hd0
    MENU DEFAULT
    MENU LABEL Boot from hard disk
    TEXT HELP
    Boot from the local hard drive.
    If you are unsure, select this option.
    ENDTEXT
    and now at least I am getting to the default menu again (looks exactly like the one in the pic. you attached)

    The first line (Boot from local drive) is highlighted and after the timer (3s) expires, the screen just flickers once and I back to the same screen and the timer is restarted again to 3s and it just loops like that forever. So there is definately some change as the D790 no longer restarts but unfortunately I can't seem to get it to boot of the HD at all. Not even if I press enter when the first line (boot from local drive) is highlighted, again, the screen just flickers and I'm back to the default menu.

    Should I perhaps try v.4.04 of those 3 SYSLINUX files insted of v.4.05 which I currently downloaded?

    All the other menu lines do work, I can get system information etc. but after the reboot I find myself in the main menu again and I can't get it to boot of the HD...
  15. BryceZ Community Manager

    SYSLINUX 4.05 did make some adjustments to chain.c32, so it is possible that a bug was introduced, and using 4.04 might help. Another thing to check; what happens when you don't PXE boot? Does it boot normally to the hard drive? Also, append hd0 tries to load the first disk drive detected by SYSLINUX, so is it possible that it's seeing another non-bootable drive on this system?
  16. Peter Nowak New Member

    Ah, good suggestions, I'll have a look at this. Again many thanks. If the D790 is not set to boot from Network with PXE as first choice, then it successfully boots from HD as first choice.

    But I will double check the HD0 as you may very well be right in that perhaps the HD is not connected to "port0" I'll have to check that.

    Cheers again BryceZ, you advice and suggestions are very appreciated
  17. Peter Nowak New Member

    Hi Bryce,

    thanks for your help and assistance! It's now working, the problem it would seem was permissions to the chain.c32 file and the pxelinux.0 file, all wokring now!

    Cheers!

Share This Page