Connection timed out?

Discussion in 'General' started by buckITall, Jan 19, 2012.

  1. buckITall Member

    I'm unable to resolve:

    tftp://0.0.0.0/pxelinux.0............. Connection timed out (0x4c126035)
    Could not boot from filename "pxelinux.0": Connection timed out (0x4c126035).
  2. buckITall Member

    I've triple checked with the IT department about the DHCP configurations options 66 and 67 being correct. I can connect and configure from other computers but cannot receive pxe boot file when restarting client computers. TFTP time out :(
  3. stark325 New Member

    Try enabling Port fast on your switches.
  4. chad-bisd Community Manager

    Why are you trying to connect to 0.0.0.0 for tftp? Does PXE boot fail on all clients, or just a certain type? Can you try wireshark to do a packet capture and see what's going on? You can check your dhcp config that way.
  5. buckITall Member

    I was trying to use gPXE boot disc on an old Dell Optiplex...found out that just press F12 brings up my network boot options :rolleyes:
    Now on to the next problem...o_O
    "PXE-E32: TFTP open timeout"
    research tells me that the client sends a request and the server receives and sends back ack along with packet pxelinux.0 but the file gets lost somehow...does this sound right?
    Now from the Dell I am able to use Windows cmd and receive the packet via tftp x.x.x.x get pxelinux.0 command. But from my workstation (right next to it) I am not.
    I've downloaded wireshark but am unaware on what to look for. If I can narrow down the issue to the DHCP server I can work better with the Network Admin.
  6. Kevin Community Manager

    Is it possible you are using a Windows DHCP server and also a Linux DHCP server? I ask because we have a setup similar to this at my place of employment. Although I don't know all of the details, I have to assume we have the Windows DHCP server to point different files at boot for different things. For instance, separating TFTP (FOG) boots and FTP (Thin clients) boots etc. And we use our Linux box to actually assign the IP addresses to the clients themselves. I know that if that's the case, you need to modify your DHCPD.Conf file to point to the TFTP server. We ran into that exact error. And if that is the case, you need to add "next-server X.X.X.X; and filename "pxelinux.0"; where X.X.X.X is the IP of your FOG server.
  7. buckITall Member

    Kevin,
    I don't know if there are other servers here in my lab. I've just started and the last guy didn't document anything. I can WOL computers using FOG but the pxelinux.0 file is getting blocked from transmitting. Is there a way to find out servers on my network without disabling each one? I've tried wireshark and even SIW but am unaware of exactly what to look for.
  8. Kevin Community Manager

    WOL I want to say works off of IPhelpers which shouldn't be affected by pxelinux.0 However, If you know for a fact that your Windows server has the correct settings for ports 66 and 67, I would assume there are three possibilities left. 1. Your DHCP server is on a different subnet than your lab. 2. You're running a Linux DHCP server as well which you would need to add the code that I previously posted. Or 3. Somewhere, a firewall could be blocking those ports. I would have the server/network guys double check the servers/firewall.
  9. buckITall Member

    The DHCP server is on a seperate subnet...is there something I have to configure on my end (FOG server) or another switch for the network admin?
  10. Kevin Community Manager

    So i'm just thinking, is your FOG server setup to do DHCP, or did you set it up to point to your companies DHCP server? This can cause issues as well. Hopefully you have setup FOG to point to your companies DHCP server. If not, you'll have to modify the DHCPD.conf file on the server a bit.
  11. kirksec Member

    Hi,

    i know i had this TFTP error and that was because my Firewall on the FOG server wasnt switched off and that SELinux was not disabled
    i dont know if it will help you but just make sure that those are both turned off
  12. buckITall Member

    I did not install DHCP service on the FOG server and correctly pointed to the DHCP server on a different subnet. The firewalls, ufw and SELinux are both off, I'm out of ideas. Now learning how to use and read wireshark to help understand where the file is getting blocked. Not looking forward to re-installing again...even thou it was pretty easy.
    If anyone has ideas or guess that would be great, otherwise I'll post any findings if I find them.

Share This Page